Alle Beiträge von raimond

efi trojan signs

Merkmale

Unter Linux und div anderen Distribution (getestet unter Debia)n ist dass er selbstständig services startet und diese injekziert. 
es liest beim starten aaaus dem zu startenden os die verfügbaren Services aus und ijektziert mehrere davon. falls einer der servieces aus irgend einen grund hämgem bleibt.
die dazu gehörogen abahängigektiten nehmen an resourcesn enorm an.

egal welches os isntalliert ist er findet dies aus
Auch wenn man services deaktiviert und es nach einen neustart bzw logout /login nachschaut, sind sie wieder gestartet.
ein deinstallieren hilft aber auch hier nicht er startet einfach ein anderes zu aktivieren.
die start dateiwen selbst su löschen hilft alcdarmlerdings nur so dass er wieder ein anderes dafür in den start zieht.

Beim start des pc wird egal welches betriebsystem installiert ist ein services welche berreits vorhanden ist injektziert und falls bzw falls noch niocht aktiviert ist eines davon einfach gestartet und dieser service ist dann
deinstallieren welche er immer wieder von selbst startet, startet er ein anderes.

ein beenden  zu erzwingen (unter Windows)einer  injekzierten Abhängigkeit die man eben an dem enormen resourcesn verbrauch erkennen könnte . ist dann umso einfacher die neuen Abhängigkeiten zu identifizeiren da irgenweöche andere Prozesse  den davor genutzte resourcen größe sprnhaft an soih nehmen.

beyond text: abhilfe sollte eigenltich flashrom sein damit man seinen efi chip wieder gesund bekommt

Simone Fink bei übergabe tätigkeiten für ihren mörderischen Vater Conny fink welcher mit hubert kern 2007 100kg cocaine erhalten hat und damit sein fkk mystic erbaut hat

Simone Fink die Tochter von Conny Fink dem FKK Mystic Besitzer welcher sich das ganze Mystic erst leisten hat können als er meinen Vater ermorden lies.
Hubert Kern und Conny Fink verteilen noch immer aus der Wohnung unter mir.
Hier wie Sie zum Spar geht und dort jemandem etwas übergibt soweit geht meine Kamera aber nicht.

 

openwrt spoof all to local web server

ganz einfacher redirect

unter /etc/config/firewall

 

config redirect
option src lan
option proto tcp
option src_dport 80
option src_ip !192.168.1.1       
 #hier die locale ip adresse vom router die nicht gespoofed werden #soll sondern alle anderen
option dest_port 80

für port http

ziel von den anfragen solllen hier landen am router

option dest_ip 192.168.1.1
option target DNAT

 

#und dsas ganze nochmal für https

config redirect
option src lan
option proto tcp
option src_dport 443
option src_ip !192.168.1.1
option dest_port 443
option dest_ip 192.168.1.1
option target DNAT

ausserdem noch hinzufügen bei
/etc/config/dhcp

config ‚domain‘
option name ‚#‘
option ip ‚192.168.1.1‘


die sollten wegkommentiert werden

#list rebind_domain example.lan 
#option local ‚/lan/‘
#option domain ‚lan‘
#list server ‚/mycompany.local/1.2.3.4‘
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain ‚64.94.110.11‘

My ptz nano

#include <SoftwareSerial.h>
#define Pin13LED         8    //green
#include <printf.h>
#include <Servo.h>
SoftwareSerial portOne(1, 0); // RX, TX
Servo servo1;
Servo servo2;
int tx_led = 7;   //yellow
int sensorValue1 =0;
int sensorValue2 =0;
int sensorPin1=0;
int sensorPin2=1;
int maxPotValue = 1023;
int currentpos=1500;
int buttonPin =2;
byte byteReceived;
int byteNumber = 0;
int byteSend;
int minPulse1     =   600;   // minimum servo position
int maxPulse1     =   2400; // maximum servo position
int turnRate1  ;  // servo turn rate increment (larger value, faster rate)
int minPulse2     =   600;  // minimum servo position
int maxPulse2     =   2400; // maximum servo position
int turnRate2 ;  // servo turn rate increment (larger value, faster rate)
/** The Arduino will calculate these values for you **/
int centerServo1;
int newposX, oldposX;
int centerServo2;
int newposY, oldposY;
int pulseWidth1,currentposX;          // servo pulse width
int pulseWidth2,currentposY;          // servo pulse width
bool updatedebug= false;
const byte tiltDown = 0x10;
const byte tiltUp = 0x08;
const byte panLeft = 0x04;
const byte panRight = 0x02;

void setup(void)
  {
  pinMode(tx_led,OUTPUT);  
  Serial.begin(57600);
  printf_begin();
  //Xee= EEPROM.read(0);
  //mycam1.attach(mycam1_p);  // attaches the servo on pin 9 to the servo object X
  //mycam1.write(Xee);        //rafu runter X
  //Yee = EEPROM.read(1);      // lese x y von eeprom  
  servo1.attach(5);
  servo2.attach(6);
  centerServo1 = maxPulse1 - ((maxPulse1 - minPulse1) / 2);
  centerServo2 = maxPulse2 - ((maxPulse2 - minPulse2) / 2);
  pulseWidth1 =  centerServo1;
  pulseWidth2 =  centerServo2;
  turnRate1 = (maxPulse1- minPulse1)/720 ;
  turnRate2 = (maxPulse2- minPulse2)/720 ;  
  Serial.println("Arduino Serial Servo Control with Pelco D");
  Serial.println();
  }

void loop(void)
      {
      sensorValue1 = analogRead(sensorPin1);
      sensorValue2 = analogRead(sensorPin2);
      Serial.print("sensor1:");
      Serial.println(sensorValue1);
      Serial.print("sensor2:");
      Serial.println(sensorValue2);
      if(sensorValue1 >= 536 && sensorValue2 <= 488){
        rightup();}
      if(sensorValue1 >=536 && sensorValue2 >=536){
        rightdown();}
      if(sensorValue1 <=488 && sensorValue2 <=488){
        leftup();}
      if(sensorValue1 <=488 && sensorValue2 >=536){
        leftdown();}
      if(sensorValue1 >=536){
      panright();}
      if(sensorValue1 <= 488){
      panleft();}
      if(sensorValue2 >= 536){
      tiltup();}
      if(sensorValue2 <= 488){
        tiltdown();}
    }

      
void leftup(){
      oldposX=pulseWidth1;
      oldposY=pulseWidth2;
      newposX=pulseWidth1+turnRate1;
      newposY=pulseWidth2+turnRate2;
      if (newposX > maxPulse1){newposX = maxPulse1;}
      if (newposY < minPulse2){newposY = minPulse2;}
      while (pulseWidth1<newposX || pulseWidth2>newposY){
        if(pulseWidth1<newposX){pulseWidth1++;servo1.writeMicroseconds(pulseWidth1);}    
        if(pulseWidth2>newposY){pulseWidth2--;servo2.writeMicroseconds(pulseWidth2);}
    updatedebug = true;
    }
      delay(10);
    }
        
void rightup(){
    oldposX=pulseWidth1;
    newposX=pulseWidth1-turnRate1;
    oldposY=pulseWidth2;
    newposY=pulseWidth2-turnRate2;
    if (newposX < minPulse1){newposX = minPulse1;}
    if (newposY < minPulse2){newposY = minPulse2;}
    while(pulseWidth1>newposX ||pulseWidth2>newposY ){
      if(pulseWidth1>newposX){pulseWidth1--;servo1.writeMicroseconds(pulseWidth1);}
      if(pulseWidth2>newposY){pulseWidth2--;servo2.writeMicroseconds(pulseWidth2);}
    updatedebug = true;
    }
    delay(10);
  }
  
void leftdown(){
      oldposX=pulseWidth1;
      oldposY=pulseWidth2;
      newposX=pulseWidth1+turnRate1;
      newposY=pulseWidth2+turnRate2;
      if (newposX > maxPulse1){newposX = maxPulse1;}
      if (newposY < minPulse2){newposY = minPulse2;}
      while(pulseWidth1<newposX ||pulseWidth2<newposY){
        if(pulseWidth1<newposX){pulseWidth1++;servo1.writeMicroseconds(pulseWidth1);}
        if(pulseWidth2<newposY){pulseWidth2++;servo2.writeMicroseconds(pulseWidth2);}
      updatedebug =true;}
      delay(10);
    }
void rightdown(){
      oldposX=pulseWidth1;
      oldposY=pulseWidth2;
      newposX=pulseWidth1-turnRate1;
      newposY=pulseWidth2+turnRate2;
      if (newposX < minPulse1){newposX = minPulse1;}
      if (newposY < minPulse2){newposY = minPulse2;}
      while( pulseWidth1>newposX|| pulseWidth2<newposY){
        if(pulseWidth1>newposX){pulseWidth1--;servo1.writeMicroseconds(pulseWidth1);}
        if(pulseWidth2<newposY){pulseWidth2++;servo2.writeMicroseconds(pulseWidth2);}
        updatedebug = true;
      }
    delay(10);
  }


void panleft(){
    oldposX=pulseWidth1;
    newposX=pulseWidth1+turnRate1;
    if(newposX > maxPulse1){newposX = maxPulse1;}
      while(pulseWidth1<newposX){pulseWidth1++;servo1.writeMicroseconds(pulseWidth1);
      updatedebug = true;}
    delay(10);
  }
  
void panright(){
    oldposX=pulseWidth1;
    newposX=pulseWidth1-turnRate1;
    if (newposX < minPulse1) 
      {      
        newposX = minPulse1;
      }
    while(pulseWidth1>newposX)
      {
        pulseWidth1--;
        servo1.writeMicroseconds(pulseWidth1);
        updatedebug = true;
      }
    delay(10);
}
void tiltup(){
    oldposY=pulseWidth2;
    newposY=pulseWidth2-turnRate2;
    if (newposY < minPulse2) 
      {      
        newposY = minPulse2;
      }
    while(pulseWidth2>newposY)
      {
        pulseWidth2--;
        servo2.writeMicroseconds(pulseWidth2);
        updatedebug = true;
       }
    delay(10);
}
void tiltdown(){
    oldposY=pulseWidth2;
    newposY=pulseWidth2+turnRate2;
    if (newposY < minPulse2) 
      {      
        newposY = minPulse2;
      }
    while(pulseWidth2<newposY)
      {
        pulseWidth2++;
        servo2.writeMicroseconds(pulseWidth2);
        updatedebug = true;
      }
    delay(10);
}

void halt() {
  //sync  cam#  Command1  Command2  Data1  Data2 CheckSum
  byte  rec[7] = {0xFF, 0x01, 0x00, 0x00, 0x00, 0x00, 0x01};  //This is the most basic instruction. Camera 1, four zeros and a check sum of one
  for (int i = 0; i < 7; i++) {
    Serial.print(rec[i], DEC);
  }
}


Zumo 32U4 robot

my zumo in action

code available at  https://github.com/bugsysunday/zumo4sun

but it isnt really finish it still need some modification 

i just modifed the example from zumo library heading  to  an oppunent .

zumo 4 free space  alias zumo4sun

from https://www.pololu.com

 

 

HORNET U-BOARD X2 64/16 aka UB64

original ub64 files if someone need that

[ ] ART.bin 2016-05-18 03:54 64K  
[ ] NVRAM.bin 2016-05-18 03:54 64K  
[ ] rootfs.bin 2016-05-18 03:54 14M  
[ ] u-boot-env.bin 2016-05-18 03:54 64K  
[ ] u-boot.bin 2016-05-18 03:54 256K  
[ ] uImage.bin 2016-05-18 03:54 1.6M  

http://dl.raimond.at/hornet-ux2/

tftpboot 0x80600000 kernel.bin
erase 0x9fe50000 +0x190000
cp.b 0x80600000 0x9fe50000 120000

tftp 0x80600000 rootfs.bin
erase 0x9f050000 +0xE00000
cp.b 0x80600000 0x9f050000 240000